1. Hardware Overview

For this configuration, we’ll use the following hardware setup:

Delta Fiber connection
Huawei OptiXstar EN8010Ts-20 XGS-PON Terminal
Mikrotik Router CCR1009-8G-1S-1S+

2. VLAN Setup

Delta Fiber operates with two VLANs:

VLAN 100: Internet
VLAN 102: VoIP
/interface vlan add interface=ether1 name=vlan100-internet vlan-id=100 add interface=ether1 name=vlan102-voip vlan-id=102

3. Bridge Configuration

We’ll create two bridges: one for LAN and one for VoIP:

/interface bridge add name=lan-bridge add name=voip-bridge

4. VRF Configuration

To separate traffic, we’ll configure two VRFs:

/ip vrf add interfaces=voip-bridge name=voip add interfaces=vlan100-internet,lan-bridge name=internet
Note: VRF (Virtual Routing and Forwarding) allows for multiple routing tables to coexist on the same router.

5. Bridge Ports Configuration

Now we’ll assign the ports to their respective bridges:

/interface bridge port add bridge=lan-bridge interface=ether2 add bridge=lan-bridge interface=ether3 add bridge=voip-bridge interface=vlan102-voip add bridge=voip-bridge interface=ether8

6. DHCP Client Setup

Configure the DHCP clients for both VRFs:

/ip dhcp-client add default-route-distance=10 interface=vlan100-internet add default-route-distance=20 interface=voip-bridge

ry=”2″> 7. LAN DHCP Server Setup

Finally, we’ll configure the DHCP server for the LAN network:

/ip pool add name=dhcp_pool0 ranges=192.168.178.20-192.168.178.254 /ip dhcp-server add address-pool=dhcp_pool0 interface=lan-bridge lease-time=1d name=dhcp1 /ip dhcp-server network add address=192.168.178.0/24 dns-server=1.1.1.1,8.8.8.8 gateway=192.168.178.1